The Longest Journey Forums  

Go Back   The Longest Journey Forums > The Guardians Realm > The Longest Journey

Reply
 
Thread Tools Display Modes
Old 02-18-2011, 08:18 PM   #1
veck
Registered User
 
Join Date: Feb 2011
Posts: 4
FMV Freezes in TLJ

Hi all,

I'm having a problem with The Longest Journey (GOG.com release). The game itself runs fine, but the FMV aren't playing correctly they all freeze on the first frame while sound plays in the background.

I've edited the pref ini to run in software mode, tried all the compatibility modes, run as admin and installed loads of different codecs along with the Rad video tools, but nothing has fixed the problem.

I'm running Windows 7 64bit on a HP G62 notebook, Intel Core i3 2.27hz, 4gb RAM with built in Intel HD Graphics. Not the greatest setup, but it usually can run older games with no problems.

It's worth noting that some other games, Planescape and Dreamfall for instance, runs its videos fine, while others (Diablo 2, Arcanum) have a similar problem as above.

Any advice on how to get this sorted would be greatly appreciated! I've run out of ideas based on the troubleshooting tips available. Thanks in advance!
veck is offline   Reply With Quote
Old 02-20-2011, 07:40 PM   #2
Miral
Random Lurker
 
Miral's Avatar
 
Join Date: Apr 2006
Location: New Zealand
Posts: 5,787
Have you tried running it in windowed mode?

The main thing to check, though, is that AA is either Disabled or Application Controlled for TLJ's game.exe in your graphics driver control panel. If it's forced on then the game will misbehave.
Miral is offline   Reply With Quote
Old 02-22-2011, 05:48 PM   #3
veck
Registered User
 
Join Date: Feb 2011
Posts: 4
Quote:
Originally Posted by Miral View Post
Have you tried running it in windowed mode?

The main thing to check, though, is that AA is either Disabled or Application Controlled for TLJ's game.exe in your graphics driver control panel. If it's forced on then the game will misbehave.
I'm not even sure if this graphics chip has the option to turn it off. I've looked about to see how I disable it if it does exist, but Google isn't bringing up much and the Intel HD control panel doesn't give the option.

As for windowed mode, I've tried it and now I'm getting a black screen with music playing whereas previously a single frame of movie would appear before it froze. I can ESC out of it easily enough but it would be great if I can get these FMVs working.

Any suggestions are appreciated!
veck is offline   Reply With Quote
Old 02-22-2011, 07:43 PM   #4
Miral
Random Lurker
 
Miral's Avatar
 
Join Date: Apr 2006
Location: New Zealand
Posts: 5,787
The only other thing I can think of at the moment is to try different graphics driver versions. (First try the latest, and then possibly try some older ones -- sometimes newer drivers break older games.)
Miral is offline   Reply With Quote
Old 02-25-2011, 10:26 PM   #5
veck
Registered User
 
Join Date: Feb 2011
Posts: 4
Unfortunately this laptop has OEM versions of its graphics drivers, so I can't really update them conventionally or seemingly go back to old versions. I'll look into it a bit more, but it doesn't seem straight-forward.

I think, having tried everything that can be done, it's just one of those things. It's probably more to do with non-compatibility with Win7 64bit than anything else. Hopefully that will get sorted down the line, but at the moment I'll just have to watch the movies outside of the game.

Thanks for the help, though!
veck is offline   Reply With Quote
Old 03-02-2011, 04:34 PM   #6
veck
Registered User
 
Join Date: Feb 2011
Posts: 4
So, as a post-script, I found a solution to my problem. It's almost so simple it's weird...

Setting my laptop battery config to 'High Performance'. Yeah, I know, wtf?

Found it completely by chance when looking through another game's tech forums (Gemini Rue, incidentally - an impressive new adventure game). It's completely sorted my TLJ FMV problem as well as the other games I couldn't run.

Apparently setting it to power saver disables DirectDraw or something silly like that. So to anyone who had this problem: set your battery to high performance and see if that helps!
veck is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:58 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.