Results 1 to 6 of 6

Thread: Mouse buttons don't work in combat mode

  1. #1
    Registered User
    Join Date
    Nov 2013
    Posts
    5

    Mouse buttons don't work in combat mode

    Hi.

    I just bought Dreamfall off GOG. It seems to be in working order otherwise, but mouse buttons don't do jacks**t when I'm in combat mode. This is weird, because they do work elsewhere in the game. The assigned keys for attacks do work, but it's not the way I want to play.

    My OS is a 32 bit Vista, and the mouse is a part of logitech keyboard/mouse wireless combo connected to a USB port. It's a standard run-of-the-mill 3-button mouse with a scrollwheel as a middle button.

    Any suggestions? Are there any settings I could tinker with?

  2. #2
    Random Lurker Miral's Avatar
    Join Date
    Apr 2006
    Location
    New Zealand
    Posts
    5,744
    It's been a while since I last played, so I don't really remember for sure, but I think you just have to use the keyboard in combat situations. Or plug in a gamepad.

    (Also note that most combat is avoidable, though there are a few that can't be avoided, as well as a few others that are intended to be unwinnable if you don't avoid them.)
    "Why not? Only one human captain has ever survived battle with a Minbari Fleet. He is behind me. You are in front of me. If you value your lives…be somewhere else!"

  3. #3
    Registered User
    Join Date
    Nov 2013
    Posts
    5

    Thumbs up

    This is from manual.pdf that came with the copy.

    Press Left Mouse Button or L to perform light attacks. Your opponent can block light
    attacks.
    Press Right Mouse Button or K to perform heavy attacks. Heavy attacks cannot
    be blocked, but are slow and can be dodged.
    Different attacks can be performed if W , A , S ,or D is pressed in combination with
    Left Mouse Button or Right Mouse Button .
    To block attacks, press and hold SPACE before the attack lands.
    To dodge attacks, press and hold SPACE while moving the character in the direction
    you wish to dodge.
    As for avoiding unnecessary combat, duly noted.
    Last edited by Lops Cack; 11-02-2013 at 07:17 AM.

  4. #4
    Registered User
    Join Date
    Nov 2013
    Posts
    5
    I've tried out using keyboard only in combat mode. I guess I'll have to make do with it, since I haven't found a solution to the mouse problem. There are a couple references on the net to other folks experiencing the same problem, but no solutions. Still, if there is a way to fix this, I'd rather like to try out which method feels better.

    Here's a new one: In the beginning of the game, some textures seem transparent. Namely, some plants. Here's a picture:

    http://image.bayimg.com/eefeb8d908c9...1610d41197.jpg

    Is this a glitch, or are those plants supposed to look like this?

  5. #5
    Random Lurker Miral's Avatar
    Join Date
    Apr 2006
    Location
    New Zealand
    Posts
    5,744
    I can't view the image. But I believe there are some holographic plants in a few places -- those are supposed to be translucent.
    "Why not? Only one human captain has ever survived battle with a Minbari Fleet. He is behind me. You are in front of me. If you value your lives…be somewhere else!"

  6. #6
    Registered User
    Join Date
    Nov 2013
    Posts
    5
    Okay, both issues are resolved now.

    Mouse buttons did work in the first "real" fight, though they didn't in the gym with Jama. It was probably some weird glitch that can't be reproduced and needed only restarting the OS (now they work in the gym, too, when starting a new game.)

    Plants are not transparent, if I set the anti-aliasing level to 1 or none (was using 3 originally.) Not sure if it was an actual error to begin with or just the way it looks with the setting, but I'm using aa=1 now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •