Results 1 to 8 of 8

Thread: Windows 8 problems

  1. #1
    Registered User
    Join Date
    Nov 2012
    Posts
    1

    Windows 8 problems

    Hi!

    I'm trying to play The Longest Journey (GOG version) in Windows 8. I haven't tested the game a lot, but the gameplay seems OK. The problem is, that when I try to exit the game, only a white box appears and I have to use the Task Manager to quit the game. It's quite annoying because the OS font changes and I have to restart the computer to get them back to normal. I'm on the 7th chapter (I saved my savegames before removing Windows 8) and I was enjoying the game a lot. Anyone knows how to fix this little issue?

    Thanks!

  2. #2
    Registered User Norwegian's Avatar
    Join Date
    Nov 2012
    Location
    Norway
    Posts
    107
    Dance gangnam style!!!!
    " They say that every story has a beginning and an end, but sometimes the two are one at the same time "

    - Zoe Castillo

    " Players do not play a game because the star is the 'wrong' gender. I don't believe that for a second "

    - Ragnar Tørnquist


  3. #3
    Random Lurker Miral's Avatar
    Join Date
    Apr 2006
    Location
    New Zealand
    Posts
    5,744
    The usual solutions for general TLJ weirdness are to try playing in windowed mode.
    "Why not? Only one human captain has ever survived battle with a Minbari Fleet. He is behind me. You are in front of me. If you value your lives…be somewhere else!"

  4. #4
    Dreamworld Member Dr. Kin's Avatar
    Join Date
    Feb 2010
    Location
    Russia
    Posts
    762
    Try compatibility mode (if there is one in Windows 8). Compatibility with Windows XP should be enough. Also try "Turn off desktop visual effects" or such
    You have a terrible temper and are totally incapable of social or domestic life? Congratulations, you are a genius!
    April Ryan versus the Prophet: the battle begins!

  5. #5
    Dreamer Flo's Avatar
    Join Date
    Jan 2007
    Posts
    242
    The quit dialogue stills works, you just can't see it. The simplest solution to gracefully exiting TLJ rather than killing the process is to move the cursor to where the "yes" button would normally be (you can see it for an instant) before opening the dialogue (using F4 rather than the menu) and then clicking into the blank box.

  6. #6
    Registered User
    Join Date
    Jun 2012
    Posts
    7
    For me, just pressing Y when the blank dialog appears seems to work fine.

    Was there any news on whether compatibility mode solved it though? And if so, how do you do that with the Steam version? Having the error left in there just seems so inelegant, even if it causes no problem. And is this the same error that causes the diary text to not be in the handwriting font that I remember? Or is that just my poor memory?

  7. #7
    Registered User
    Join Date
    Aug 2014
    Posts
    1
    Sounds like the OP was content leaving the issue unresolved. I'll keep the torch going if anyone would like to troubleshoot with me? Here's the situation, whenever I click the Quit icon or any menus pop up, really, they show up as blank white boxes. When this happens, the mouse ceases functioning as well so clicking in the same location as the buttons is not an option. While clicking Y does let me quit out, it is rather awkward that it occurs at all. I have tried compatibility mode with XP Service Pack 3 and 2 but neither changed anything so far as I could tell. Otherwise, everything is per normal on the GOG version of the game. I'll try some more compatibility tests to see if I find something that works. If anyone has any ideas, I'd be happy to try them out. Oh and I'm running Windows 8.1 fully updated for what that's worth.

  8. #8
    Registered User
    Join Date
    Aug 2014
    Posts
    1

    Best compatibility for Windows 8 and 8.1

    Ok. So I have pretty much figured out the best way to play the game.

    Step 1: If you have already run the "Configure.exe" file then you will need to navigate to C:\Username\APPDATA\Roaming\The Longest Journey\ and open the "Preferences.ini" file. After opening the file go down to underneath where it says DIRECTX and add this line: bool_StartFullscreen=0 then save your changes and exit.

    Step 2: Right click on the game shortcut and go to compatibility and select to run it in windows xp service pack 3 mode (this will fix the cutscene issue in windowed mode)

    Step 3: Play your game and enjoy it and do as the previous guy said when you select to quit the game and the white box appears just press the Y key on your keyboard.

    P.S. - I have only tested these changes on the GOG.com version. But I assume it will work the same for any version out there.
    Last edited by xSimply1337x; 08-31-2014 at 05:02 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •